Join the C34 Association Today!
[C34 Home] [C34Tech Notes] [C34 Tech Wiki] [Join!]
Please login or register.
Advanced search  

News:

Pages: 1 [2]   Go Down

Author Topic: Running warmer and possible exhaust leak  (Read 4651 times)

0 Members and 1 Guest are viewing this topic.

mtullier

  • Forum - Petty Officer 3rd Class
  • ***
  • Karma: 1
  • Posts: 85
    • View Profile
Re: Running warmer and possible exhaust leak
« Reply #15 on: November 07, 2012, 02:57:13 PM »

Check to make sure that your thermostat is opening properly and has no restrictions. 
Logged
Mike

noworries

  • Forum - Petty Officer 2nd Class
  • ****
  • Karma: 1
  • Posts: 193
    • View Profile
Re: Running warmer and possible exhaust leak
« Reply #16 on: November 07, 2012, 03:44:24 PM »

Thanks for all the info.  It looks like the hard part is getting it off the motor, so I'll work that angle first, then take it off the muffler, then strip it down and see what it looks like.  One of the threads had a picture of the part so knowing it's all one piece helped.
Logged
1991 Catalina 34 Mark 1.5 w/ M35

Stu Jackson

  • C34IA - Secretary
  • Forum - Master Chief Petty Officer of the Navy
  • ********
  • Karma: 68
  • Posts: 7586
    • View Profile
Re: Running warmer and possible exhaust leak
« Reply #17 on: November 07, 2012, 05:16:36 PM »

Logged
Stu Jackson, C34 IA Secretary, #224 1986, "Aquavite"  Cowichan Bay, BC  Maple Bay Marina  SR/FK, M25, Rocna 10 (22#) (NZ model)

"There is no problem so great that it can't be solved."

Mark Sutherland

  • Forum - Petty Officer 2nd Class
  • ****
  • Karma: 0
  • Posts: 124
    • View Profile
Re: Running warmer and possible exhaust leak
« Reply #18 on: November 08, 2012, 02:09:15 PM »

For what it's worth, when I bought my 1986 C34, it ran at about 190 degrees.  I immediately a)Demineralized the RW system with an Ascylic Acid solutions, b)I installed a new OB RW pump, and c)I replaced the thermostat.  I also cleaned the contact for the temp sensor at the engine to make sure it wasn't fouled and sending a bad temp reading.  My engine has run at 162 degrees since(2 years).
Logged
Dunrobin II, 1986 C34 MK1 #170

Stu Jackson

  • C34IA - Secretary
  • Forum - Master Chief Petty Officer of the Navy
  • ********
  • Karma: 68
  • Posts: 7586
    • View Profile
Re: Running warmer and possible exhaust leak
« Reply #19 on: November 08, 2012, 02:19:45 PM »

We also should point out that they make two different thermostats:  160 & 180.
Logged
Stu Jackson, C34 IA Secretary, #224 1986, "Aquavite"  Cowichan Bay, BC  Maple Bay Marina  SR/FK, M25, Rocna 10 (22#) (NZ model)

"There is no problem so great that it can't be solved."
Pages: 1 [2]   Go Up