Join the C34 Association Today!
[C34 Home] [C34Tech Notes] [C34 Tech Wiki] [Join!]
Please login or register.
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: new Danfoss Controller not working?  (Read 141 times)

0 Members and 1 Guest are viewing this topic.

Joyride

  • Forum - Seaman
  • **
  • Karma: 0
  • Posts: 31
    • View Profile
new Danfoss Controller not working?
« on: November 21, 2019, 05:50:12 PM »

Hey gang,

I've been trouble shooting my adler barbour cold machine and coming up empty.  About 2 years ago I bought a new module but never put it on because I found I had a bad thermostat after I used a jumper between the T and C.  The new thermostat solved the issue and I've been running it fine since then. 

I'm getting 12.6v to the pc board and then to the Danfoss(secop) module reads same.  The compressor doesn't come on, or fan, and I get no blinking lights.  I found the module that I bought before and put that on.  Same thing, power, no fan, no compressor, and no lights.  I also ran the thermostat jumper again and that did not help. 

Also when I click on the power I'm not even getting a voltage drop as if the compressor is trying to turn on.

Is there a way to test that the module is sending power to the compressor?   Fuses on the pc board are fine.  Are there any fuses in the control module?
Logged
1991 Catalina 34 (mk 1.5) Universal M35 Wing Keel

Stu Jackson

  • C34IA - Secretary
  • Forum - Master Chief Petty Officer of the Navy
  • ********
  • Karma: 68
  • Posts: 7510
    • View Profile
Re: new Danfoss Controller not working?
« Reply #1 on: November 21, 2019, 08:01:12 PM »

jr,

Don't know if you've sen these from the 101 Topics thread:

Fridges 101 (Adler Barbour Repairs & Troubleshooting from Richard Kollmann)

http://c34.org/bbs/index.php/topic,6956.0.html

Fridge Follies 101 - to prove that Richard is right and that 99% of fridge issues are electrical & includes electronic module resource

http://c34.org/bbs/index.php/topic,3044.0.html
Logged
Stu Jackson, C34 IA Secretary, #224 1986, "Aquavite"  Cowichan Bay, BC  Maple Bay Marina  SR/FK, M25, Rocna 10 (22#) (NZ model)

"There is no problem so great that it can't be solved."

Ken Krawford

  • Forum - Petty Officer 2nd Class
  • ****
  • Karma: 3
  • Posts: 109
    • View Profile
Re: new Danfoss Controller not working?
« Reply #2 on: November 23, 2019, 03:42:33 AM »

I've had problems with the PC board on my unit - burned 10 amp fuse and burned traces on the board.  I found a used board and that worked for one day and then died.  As I understand it, the PC board is basically a diagnostic device with the LED blinks telling you why your system isn't running.  I ran the pos. and neg. 12VDC leads directly to the Danfoss module and the system is now working.
My conclusion (right or wrong) is that my replacement PC board is also fried.  I've also found Adler Barbour's phone support to be very good.  Little or no hold time and knowledgeable techs on the other end.
Logged
Ken Krawford
C350 Hull 351  2005 Universal M35B
Pages: [1]   Go Up