Join the C34 Association Today!
[C34 Home] [C34Tech Notes] [C34 Tech Wiki] [Join!]
Please login or register.
Advanced search  

News:

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Mark Swenson

Pages: [1]
1
Catalina 34s for Sale / Re: wanted to buy c34 in PNW
« on: December 04, 2010, 04:54:19 PM »
The 1990 C34 is back on Craigslist today...

http://seattle.craigslist.org/sno/boa/2095082241.html

2
Catalina 34s for Sale / Re: wanted to buy c34 in PNW
« on: December 01, 2010, 05:50:57 PM »
I've seen one listed on the Seattle Craigslist a few times lately.  I think it's a 1990.  There's also been a 1989 C36 there a few times too.  I think it's out of Port Townsend.   Even though you want a 34, take a look at the 36 too.  I really wanted a 34 a few years ago, but couldn't find a good one in the Seattle area.  I ended up with a great Catalina 36 instead!  Good luck!

3
Main Message Board / Re: New Sails
« on: November 26, 2009, 12:34:54 PM »
Go over to the Catalina 36 forum and contact Chic Lasser.  Chic sails a Catalina 36 and also is a rep for Mack Sails.  I bought a new main and Genoa from him last year about this time and found the prices to be very good and the quality of the sails also to be very good.  You may also be able to find Chic's e-mail in the most recent Mainsheet in the C36 section.

4
Main Message Board / Re: Heat Exchanger
« on: March 14, 2009, 05:48:19 PM »
Sorry I don't have the dimensions, but I was changing all the fluids yesterday on my C36 and noticed both brackets on my M25XPB (with only 80 hours) are broken.  I checked the parts list for the engine and it does not list the brackets.  Instead, there is a part that the brackets appear to attach to.  My engine does not have that item.  I'm going to check with the Universal distributor in Seattle this week to see if they have the brackets, although I am concerned that both brackets failed with only 80 hours on the engine.

5
Main Message Board / Re: Mack sails
« on: February 28, 2009, 07:07:30 PM »
I just got a new Main and Genoa from Mack for my C36.  I put them on the boat about a month ago, but haven't had an opportunity to put any wind in them yet.  I had been looking  for new sails and another C36IA member told me about Mack.  All the research I did made me believe I was making the right decision.  Their price was certainly very good and they were made in the US.  It also didn't take very long to get them.

6
Main Message Board / Re: signature honey teak
« on: January 01, 2009, 03:30:27 PM »
I have a 1989 C36 that I bought a year ago.  The teak was in terrible condition.  The previous owner had put Cetol on top of dirty green mold.  He should have been jailed for what he had done to the teak!  I took everything that was removable and brought it home last winter.  I used an orange based (nontoxic) stripper that I got at home depot to remove all the old Cetol.  It worked amazingly well.  I refinished all the exterior teak with Epithanes rather than Cetol and am very pleased with the results.

The interior teak also needed attention.  I used Daly's Sea-Fin and rubbed it in using artificial steel wool.  It looks great now!

7
Main Message Board / Re: Salon table spider
« on: January 20, 2008, 02:21:38 PM »

I think I saw a 2 3/8 spider in the West Marine catalog.  You might also try Cabelas.  I was in one of their stores over Christmas and saw some, but wasn't sure what size I needed at the time.  I got lucky.  One of my coworkers had an extra one from an old camper and gave it to me last week.

8
Main Message Board / Re: You Need A Bigger Boat!
« on: June 17, 2007, 09:10:33 AM »

Rick - thanks for the kind offer.  I'll keep this in mind.  There's a 34 listed in Yachtwold at Dana Point that I may make some inquiries on.

Paul (Tess Too) - this is the first real (recent) data point on shipping costs.  Thanks!  And by the way, I've got the Catalina 30 on L dock (L-45) right behind you and to the north a few slips (no name on transom). 

9
Main Message Board / Re: You Need A Bigger Boat!
« on: June 12, 2007, 01:12:34 PM »
Thanks for a ll the replies!  I have also looked in Yachtworld.  There is one listed there at Dana Point that sounds nice.  A couple of others I've checked on are already sold, but the brokers haven't updated the boat's staus.  I haven't been brave enough to inquire about shipping costs from California to Seattle.  I suspect it won't be a small cost, but suspect for the right boat it would be worth it.

One thing I've noticed in Yachtworld is that the price of boats in Canada (shown in US Dollars) seems to be very significantly more than those listed in the US.  Does anyone know why?

10
Main Message Board / You Need A Bigger Boat!
« on: June 11, 2007, 06:25:14 PM »
I hope I've put a good idea into some of your heads!  I currently own a Catalina 30 and would like to move up to a Catalina 34 soon.  Unfortunately, not too many of you seem to be in the mood to sell right now.  You guys have a great web site that I've found useful as a Catalina 30 owner over the years.  With any luck, someone will list a 1988-1992 Cataline 34 soon in the Northwest!

11
Main Message Board / Kayak
« on: May 26, 2005, 12:25:30 PM »
Kayaks are a great way to get into areas that no other boat can get in to.  I prefer singles, but hauling two singles along can be a hassle.  If you get a double, look for one that is long enough (between cockpits) that you don't have to synchronize your paddling.

12
Main Message Board / starting problem - batteries?
« on: October 05, 2004, 12:22:20 PM »
Thanks for all the input.  I hope to make it up to do some more troubleshooting one evening this week!

13
Main Message Board / starting problem - batteries?
« on: October 03, 2004, 06:35:09 PM »
Just got back from the boat.  For the first time ever, it didn't start on the first turn of the key.  I've got an M25.  After pressing the glowplug button for about 25 seconds, when I turned the key all I got was some clicking sounds.  No turning of the engine what so ever.  I tried each battery and then both.  Same thing.  The charger panel indicated both batteries had a full charge.  The batteries are just over 6 years old (AGMs).  Could it be anything but the batteries? :(

Pages: [1]