Join the C34 Association Today!
[C34 Home] [C34Tech Notes] [C34 Tech Wiki] [Join!]
Please login or register.
Advanced search  

News:

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - bayates

Pages: [1]
1
Catalina 34s Parts & Pieces For Sale or Wanted / C34 3 blade fixed prop
« on: January 05, 2020, 05:12:43 PM »
It is a three blade fixed prop from a C34 MKII. I replaced it with a folding prop.   Asking $35 plus shipping.

2
Main Message Board / KIDDE Fire Extinguisher Recall
« on: November 02, 2017, 03:27:33 PM »
All,

I just found there is a safety recall on Kidde fire extinguishers built from 1973 through August this year. There is a chance it may not discharge. Here is the link for you to see if yours is on the list.   http://www.kidde.com/home-safety/en/us/

One of the ones on Hakuna Matata is on the list so they will replace it.

3
Main Message Board / Windless article
« on: August 29, 2017, 04:41:29 PM »
Does anOne have a copy of a 2013 MainSheet article from the C36 association on replacing the 500 VW windless. I am getting ready to replace mine and I saw revenge to it but got rid of old issues when we moved and downsized.

4
Main Message Board / Trim Ring in Cabin on Mast Post
« on: August 06, 2017, 03:38:39 PM »
So the plastic trim ring around the mast post is starting to disintegrate and break. The sealant it holds up is slipping down. Is this a major issue or just silicone and an esthics trim ring. Is there a replacement?  If there is a replacement it must come in two pieces.

Brian
Hakuna Matata
C34 MKII 2000
#1517
San Diego

5
Main Message Board / Cabin Lights
« on: August 04, 2016, 04:56:22 PM »
We started to have issues with the cabin lights oh the Hakuna Matata. We would turn on the breaker and sometimes they came and sometimes not. So in troubleshooting I replaced the breaker and searched out all the scotch lock connectors I could find and fixed them. Still no worky.

So I called in a friend who owns Mark's Marine Electric in San Diego to help troubleshoot the issue. After about 15 minutes he found 2 more scotch lock connectors buried deep behind the electrical panel inside wire loom. You could see right away they were the issue.

Once replaced the lights were back up.

What was Catalina thinking using scotch locks in the first place,they are not to code,  then burying them deep so they were not easy to find.

Just need to put it all back together this weekend.

Another good learning

6
Main Message Board / Distribution panel breakers
« on: July 26, 2016, 04:59:14 PM »
Looks like the breaker for the cabin lights is wigging out. I looked at the breaker and could not figure out the size.  Figure either a 15 or 20 AMP. Is there a list of the various sizes that were installed from the factory?  I want to buy spares and have some of each?

7
Main Message Board / Cannot post pictures from ipad
« on: July 20, 2016, 02:59:53 PM »
OK. I am sure there is a trick, how do I post pictures from my my IPAD. Need to get pictures to Maine Sail or Stu.

8
I have a xantrex link-lite that I have put the gotcha settings in.  I have installed 2 100W panels with  Victron controllers wired to the batteries. It is on the correct side of the shunt. Yet even after a sunny day in Catalina where I am getting 5Amp per hour from each panel the victrons go from bulk to absorption to float so the batteries appear charged but the xantrex does not update accordingly.

Would like it all to work together. Any suggestions or help would be appreciated.


9
Main Message Board / PSS vent hose issue
« on: May 14, 2016, 09:10:33 PM »
So I have a weird issue on the Hakuna Matata. I got all the HX and Riser re-installed but during testing noticed the the vent loop for the PSS Dripless push water into the engine compartment when in reverse and over 1900 RPM. It does nor do it in forward at and speed. So I raised it thinking it may be to low to no avail. I checked the similar install on another C34 MKII and they have no issue in reverse at any RPM.

Looking for ideas or suggestions.

Brian

10
Main Message Board / Exhaust Riser is DEAD
« on: May 01, 2016, 04:13:30 PM »
What started out as a good weekend quickly went down hill.  Picked up all the parts to re-install the refurbed heat exchanger with new hoses and got it all done yesterday. I noticed a broken clamp on the raw water input from anti-siphon and replaced it no problem.  The I noticed a pin hole in the hose from riser to muffler and new I had to replace it.  So I did lots of reading here last night and decided to use a Ventus hose based on a post from Roc. So I cut or the old hose and when I went to remove it from the exhaust riser it just broke off in my hand. It was corrorded to no end. So I took the riser off the engine and now have more questions on what to order:

1. Do I need to send the old one to Catalina Direct to get the new one?
2. Do I need to remove exhaust flange from engine and replace it?
3. In one post it said to use something else with the flange gasket, cannot find the post again.
4. Any tricks to re-installing this.
5. I know I need to wrap the exhaust. Do you recommend the jacket from CD or use regular much let / header wrap.
6. I am ordering all new stuff so I do not have to do this again, any other suggestion to look for?

I could occasionally smell a little exhaust underway and knew I had a leak somewhere but could not find it, so maybe all this will fix other little issues.

Thanks in advance.

Brian Yates
Hakuna Matata
2000 MKII # 1517
M-35B

11
I am getting ready to run the wires for my solar panels (mounted on bimini) to the solar controllers which will be mounted on starboard side near batteries adn water heater compartment.  Is there a chase / channel that I can use to run the wires through?

12
Main Message Board / Reefer Help
« on: September 08, 2013, 07:07:14 PM »
I had a leak in the evaporator in the Adler Barbour unit.  I had the leak repaired and the unit vacuumed and recharged.  It appeared to be all OK.  Now the unit runs constantly (did not do it previously) and there is significant condensation coming off the lines from the compressor.  It is so much it leaks into the bulkhead where the thru-hull for raw seawater is located in measurable amounts.  I am sure some one has seen this before and resolved it.  I do not want to buy another unit.  Better stuff to spend a boat unit on.  I am worried about the unit not shutting off as it used to and the draw on the battery bank.

13
Main Message Board / Hobbs meter on EU 2000
« on: March 22, 2013, 04:52:45 PM »
Anyone here install a hobbs / hour meter on an EU2000 Generator.  Found one online and would like it for maintenance.

14
Main Message Board / Black water in bilge
« on: November 25, 2012, 04:48:17 PM »
Looking at pretty disgusting black water in the bilge.  It is not greasy or oily so do not suspect diesel or oil.  Also checked holding tank which is empty and has no visible leaks or wet areas near it.  I have see the threads on exhaust hose or muffler leaks.  Whatever it is left black residue in bilge.  The Hakuna Matata is a 2000 MKII.  I would like some help on how to troubleshoot and determine if that is the issue.

Brian

Pages: [1]