Join the C34 Association Today!
[C34 Home] [C34Tech Notes] [C34 Tech Wiki] [Join!]
Please login or register.
Advanced search  

News:

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - reedbr

Pages: [1] 2 3 ... 12
1
Catalina 34s for Sale / Re: 1997 C34 MkII Chesapeake Bay (sold)
« on: July 07, 2014, 12:56:05 PM »
This boat has been sold. Good luck with her David!

2
Catalina 34s for Sale / Re: 1997 C34 MkII Chesapeake Bay
« on: May 12, 2014, 09:23:41 PM »
Interior pictures:

3
Catalina 34s for Sale / Re: 1997 C34 MkII Chesapeake Bay
« on: May 12, 2014, 09:19:35 PM »
The boat is still for sale and finally got the attention she's deserved. I've dewinterized, hauled, cleaned, fresh bottom paint, oil changed, both fuel filters changed, new dodger glass, HX zinc changed, jib washed and weather band restitched. I've got new pictures from this weekend.  Thanks!


4
Catalina 34s for Sale / Re: 1997 C34 MkII Chesapeake Bay
« on: January 10, 2014, 10:23:27 AM »
Curt-

Thanks for the reply. The boat is two hours from me so just let me know when you want to do an Annapolis/Chesapeake area trip and I'll work around your schedule. The sails are original. The main was renewed by SailCare a couple years ago and came out great. The 135 jib is good but needs a restitch, especially the Sunbrella weather band. The shape is still good. I'll take care of jib maintenance this winter. The Raymarine depth, autopilot and knotmeter are original and in good working condition. The GPS I upgraded. I feel like I didn't give her the maintenance attention she deserved last year, but in reality she is in good condition overall. I am light on recent pictures but attached two here.

Let me know if you have other questions here or call me. Thanks.

5
Catalina 34s for Sale / 1997 C34 MkII Chesapeake Bay (sold)
« on: December 20, 2013, 03:13:03 PM »
$58,000 no broker price. As far as I can tell, still the lowest price C34 MkII in the US.

Two kids in college, the boat needs to go soon. In April I'll dewinterize it and take it to a broker. For now I thought I would put a quick post in and see if somebody wants to do the extra legwork and save the 10% commission. I'm told listing price with a broker would be about $65K, so I'm offering it here pre-broker for $58K.

"Ambitious" is a 1997 Catalina 34 MkII with the wider walk-out transom. Hull #1365, shoal draft wing keel and a standard rig. I have owned her since 2002 and I think I'm the third owner. The engine runs well, starts easy and has about 1050 hours on it. All the standard stuff for MkII's is there and operational: hot and cold pressurized water, refrigeration, self tailing winches, autopilot, depth meter, knot meter, and a couple anchors including my 33# Bruce that has never failed me. It also has a reverse cycle air conditioner/heat unit that works well in both modes. She is a white hull with navy blue canvas including dodger and bimini, roller furling jib and Dutchman main system. Garmin GPS system is included, as are pots, pans silverware and dishware. Beyond a good cleaning, hull wax and bottom paint, she won't need much for the coming season. Cosmetically she cold use some interior varnish and new sheer stripe tape.

Optional is an 8' sailing Trinka dinghy that I carry on Weaver davits on the stern.

Ambitious is layed up for the winter in the water on the St. Mary's river, off the Potomac in the lower Chesapeake Bay. That's Drayden, MD from the land side.

Contact me if you have any interest or questions.


Thanks.

6
Main Message Board / Re: Oil pan, early MKII's
« on: June 25, 2013, 03:17:20 PM »
That's a lot of friends/beer.

For a Kubota interchange on the M35B, research so far points to the 05 series engine, V1305 which looks like it comes in a Kubota F3060 mower and B2710 tractor. This is a best guess so far. I'm not sure how to verify.

7
Main Message Board / Re: Oil pan, early MKII's
« on: June 20, 2013, 01:52:27 PM »
Wow, I hadn't looked that part up yet. It is pricey.

Your winter starts before mine. Make sure you let me know if that pan will come off or not without jacking the motor. I agree it looks like there might be enough room, depending on how low the rods and pickup tube go.

I found this, almost all the way down it notes "just enough clearance for the pan":
http://www.c34.org/projects/queimada/m25xp/

I found this kubota engine naming convention, which my best guess might put the M35B as a Kubota V1305:
http://www.kubotaengine.com/products/engines/engine-model-name-identification

8
Main Message Board / Re: Oil pan, early MKII's
« on: June 19, 2013, 02:51:17 PM »
Here are the pictures.

Pic1 is the front of the engine, I circled the drain hose on the front of the pan and the dipstick tube coming out the side of the pan.

Pic2 is the oil pressure sensor with the oil filter removed. Note if you want to put a guage in, it looks like there is a second npt threaded port to hook into, just remove the plug.

Pic3 is a poor angled shot, but this is the starboard side of the pan where the dipstick tube attaches in the middle. I removed this whole tube to insert a hose right into the side of the pan to get more oil out. I don't want to do that every time though. I was not able to get a tube down the dipstick tube without removing it. it got hung up on something.

Thanks Tony for the help on picture posts. That is much easier.

9
Main Message Board / Oil pan, early MKII's
« on: June 19, 2013, 01:26:25 PM »
I had an oil pressure alarm on my boat a few weeks ago. First I want to say thanks to those who gave me advice here, and especially to Ron who picked up the phone to help work out a solution. I think my problem is solved, but I still need help for a permanent solution on one item. Also, I did five things at once so I have no idea what my specific solution was, or if maybe my problem is just lurking to surface later. The alarm was intermittent at the time.

I need help on a permanent solution for #4.

What I did:
(1) Replaced the oil pressure sensor. It is a $15 part and is right behind the oil filter on my M35B. The connections were a little corroded when I took the old one off.
(2) Replaced the Sherwood raw water pump. This is probably unrelated, but it was weeping water through the weep holes and leaking oil where it attaches to the gear case. $370 at Engines1 in Norfolk, plus $3 for the gasket that is not included.
(3) Drained the oil and sent to to Blackstone Labs in Fort Wayne, Indiana. For $25 a sample, they read the tea leaves and told me that for the hours on the oil (9 on the recent sample, 50 on last fall's oil change sample) I had high iron content. I talked with Ron about this and we determined that my oil changes were incomplete. I was only getting 2-1/2 quarts out plus whatever was in the filter, and this should be a 4 quart engine.
(4) I took a closer look at my oil pan factory drain hose and realized the drain was in the bottom FRONT of the pan, not the back. When the engine is mounted at an angle, this matters. I removed the dipstick mount which is in the middle and wiggled a hose to the back and removed another almost two quarts.
(5) Put in new oil and a new filter.

I ran it about 7 hours on a trip last weekend and I did not have any issues. On the trip I rafted up to a 2005 C34 owned by my friend Jeff. Jeff showed me his engine, also an M35B, and his drain hose is attached to the back side of the pan, much lower than mine. His dipstick was mounted differently too. Basically, the oil pan was completely different.

So my question is, how do I get a lower drain hole for my oil pan? Is there enough space to drop the pan without raising the engine? Can I remount the factory drain hose lower in the pan? Should I just buy a new oil pan? And, how many years was production like this? MkII's started in 96 and mine is a 97, hull #1365. I assume I am not the only one.

I have a couple pictures. Can I post them directly here or do I have to host them somewhere else?

10
Main Message Board / Re: Sink drain assembly with plastic elbow
« on: June 19, 2013, 12:53:46 PM »
I busted mine this spring on my MKII trying to get it off. I had the same question, what is the right way? It seems like it is caulked in there. I've been having troubles getting the right parts to replace it from Home Depot. Sure, the bar sink strainers are there and look much more useful, but how to go from 2" threaded to 1" barbed with a right angle in there? I've got a pile of 4 fittings per side that I need to glue together to make the transition and bend, and I'm hoping it doesn't hang down 6 inches or more when I'm all done. That's my pot & pan storage area.

The post he is referring to is here:
http://www.c34.org/projects/kindred-spirit/sink_drain.html

and this one:
http://c34.org/bbs/index.php?topic=6310.0

Here is the original part, at least for my boat:
http://www.boatparts.net/plumbing-accessories/galley-pump/faucet-combo-systems/forespar-907017-1-id-sink-waste-90-deg-sw-4/

The more I look at it, the more I think the white 90 degree bend and the black ring need to spin together, i.e. undo the hose barb connection first. Good luck.

11
Main Message Board / Re: Chesepeake Bay Warning
« on: June 19, 2013, 11:38:11 AM »
I second this. Growth is off the chart this year. I'm on the Potomac. I usually haul my boat every other year and have to dive the prop in the second season to scrape it. This spring, year two on a double coat of ablative, I dove the prop and cleaned extrememly heavy growth off the prop, shaft and strut. I dove my dad's boat three weeks later and his was the same. I went back to mine at the same time since I had the gear on and air in the tank. In three weeks, it had grown a full coat of small barnacles on the prop and shaft. I scraped it again. Last weekend I was going on an 80 mile trip. Before I left I dove it again, just two weeks after my second scraping. It again had a full coat of small barnacles on the prop and shaft. Inspecting the rest of the hull, I had some small growth near the waterline, and huge growth on the knotmeter plug (paddle wheel was removed) and depth sounder transducer.

I'm on the Magothy now, we'll see if this growth pace continues.

On the water tank, Harbor Freight sells plastic welders. I have used it one on a lawnmower gas tank (yes, dry and empty). It does work, but it takes practice and a complete match on the filler stick you use.

12
Main Message Board / Re: Sherwood Redux
« on: June 06, 2013, 09:59:36 AM »
Following up on this, I called DEPCO as suggested and they gave me the following estimate for my Sherwood pump:

Basic parts: $232.26
Shaft (if needed): $126.03
Labor: $50
plus shipping (both ways)

I came up with $325-$450. Instead I just bought a new pump from Engines1 in Norfolk for $368 plus tax (free shipping). Depco also said they would sell me a new pump for $458.10. Nice guys and very helpful at both DEPCO and Engines1. The website at  marinedieselsdirect.com (Torresen) is the best for research though.

I might buy some seals and do a cheap rebuild of the old one myself for a backup too. Thanks for everybody's help.

13
Main Message Board / Re: MarkII, water-heater slow leak
« on: May 29, 2013, 08:51:17 AM »
I'll add my vote to the problem being fittings and not the tank itself, especially if your boat is only 10 years old. You can replace most fittings in-place with some cussing and about 4 knuckles, plus maybe $20 of large sockets. Otherwsie, remove the square tank (a geometry puzzle), remove the round aluminum tank from its square galvanized box and inspect everything. I ran a pressure test on my MkII water heater some years back using a hose bib and a garden hose to make sure my new fittings didn't leak. I also cut a notch in the fiberglass locker opening to make reinstallation easier.

14
Main Message Board / Re: Sherwood Redux
« on: May 29, 2013, 08:29:32 AM »
Tony, that pump rebuild page was good.

Jack, I'm the only person who has touched this engine in the last 10 seasons so I'm pretty sure my pump life is luck and not skill. I change my impeller every other year, use some waxy water pump grease the yard gave me once, leave the impeller in over the winter and the boat winters in the water every year but one so far. I close all seacocks when I leave the boat and don't leave it plugged in to shore power when I'm gone (mostly because I've still got the original Flyback charger). I cruise at 2000 rpm, change the oil every fall and the strainer every spring. I winterize with propylene glycol. My cruising ground is brackish water. I don't think there is anything on the list that 80% of the forum users don't do, so I guess I'm just lucky so far.

15
Main Message Board / Re: Sherwood Redux
« on: May 28, 2013, 02:42:43 PM »
Ron-

Thanks for the reply. I see signs of leaking in that raw water pump area, but the pump is never wet or oily directly at the weep holes when I look. I've been watching it to find the smoking gun, but when the oil pressure alarm went off Monday I took it as my sign to start replacing parts. I realize the two are probably unrelated. My oil leak could be the pump to block gasket (or pump to head, I can't remember which). The rusty water could be the raw water seal. While I haven't seen the weep holes wet, the amount of corrosion right there leads me to believe the raw water seal is shot at a minimum and not something else like a leaking hose.

So I'm narrowing my options down to:
(1) New pump $360 (Engines1 in Norfolk)
(2) DEPCO (FL) rebuild (any estimate on the cost?)
(3) Cheap it out and do a raw water seal and pump-to-block gasket and watch it some more.

I'm cheap but $360 isn't much in the marine diesel world these days. The only tool I don't have is a hydraulic press, but I can get access to one if needed. You're an old aviation mechanic and you've got over 2000 hours on your M25, right? What would be your next move? The boat is 2 hours from home and I only get down there about twice a month.

Pages: [1] 2 3 ... 12